Flarum V1.2 sürümü yayınladı

  • Admin

    Flarum da bir hediye getiriyor! Hata düzeltmeleri, performans iyileştirmeleri, erişilebilirlik düzeltmeleri ve bazı güzel özellik eklemelerinden oluşan 240′tan fazla taahhüt içeren Flarum v1.2′nin piyasaya sürüldüğünü duyurmaktan çok mutluyuz . 🤯Dönüm noktasında kapatılan 105′ten fazla sayı ile bu, Flarum’un bugüne kadarki en büyük ikinci yayını. Bazı önemli noktaları görelim:

    • 📑Artık README belgeleri bir uzantı sayfasında görüntüleyebilirsiniz.
    • 🎨Görünüm sayfasındaki renk girişleri, seçilen rengin bir ön izlemesini görüntüler.
    • 🏷️Etiket gereksinimlerini atlama iznine sahip kullanıcılar artık davranışı UI aracılığıyla değiştirebilir.
    • ⌨️Yeni kullanıcılardan kayıt sırasında artık bir takma ad istenir.
      👮Askıya alınan kullanıcılara artık ilk ziyaretlerinde askıya alma ayrıntıları gösterilir.
    • 📬️ Akismet’in tamamen yeniden yazılması, PHP8 uyumluluğu eklenmesi, Akismet’i atlama izni, bariz istenmeyen e-postaları hemen silmek için bir yapılandırma seçeneği ve diğer yeni özellikler.
    • ♿Çoklu erişilebilirlik sorunları düzeltildi.
    • ✨CSS kod tabanı artık esnek CSS özel özelliklerini kullanıyor.
    • ⚙️Geçiş tabanlı varsayılanları değiştirmek için varsayılan ayarlar genişletici tanıtıldı.
    • 🗃️Geliştiriciler artık yeni bir genişletici ( flarum/core#3167 ) aracılığıyla blade şablon ad alanlarını değiştirebilir.
    • 🪝Ayarlar genişletici aracılığıyla yapılandırma değişkenleri olarak kaydetme ayarları tanıtıldı.
    • 🐛 Birçok hata düzeltildi.
    • 🚅 Performans daha da geliştirildi.

    ⤴️ Yükseltme

    Yükseltmeden önce public/assets dizininin, composer.json dosyasının ve veri tabanının bir yedeğini aldığınızdan emin olun!

    Yükseltme işlemine başlamadan önce, Yönetici Kontrol Panelinizden veya php flarum info yazarak Flarum 1.0.0 veya üzerinde olduğunuzdan emin olun. Değilseniz, önceki bir sürümden yükseltme yapmak için önceki sürüm notlarını kullanın.

    1.0 veya 1.1′den 1.2′ye yükseltmek için yükseltme kılavuzu belgelerine bakın . İşlem, kırılma değişikliklerinin olmaması nedeniyle önceki ana sürüm yükseltmelerine kıyasla çok daha kolay olmalıdır.

    composer update --prefer-dist --no-plugins --no-dev -a --with-all-dependencies
    php flarum migrate
    php flarum cache:clear
    

    Sürüm notlarına bakın


  • merhaba ben dosyaları bulamadım nasıl indircem ?

  • Admin

    @Muhammet-Vural Flarum’u terminal erişimli bir hosting de composer ile kurmanız gerekiyor.


Benzer Konular